Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jsquizz

Pages: [1] 2 3 4 5 6 ... 22
1
MP Server / corrupted trace file - 10.1.0.4
« on: Today at 05:42:24 PM »
I'm running on - CMOD 10.1.0.4, RHEL 7.4, DB2 11, ICOS..

Has anyone ever seen this in 10.1 (or even an older version...)

I did a system trace (ALL=15) and I'm trying to format the trace file so I can take a look at it..

[jeff@cmodtech tmp]$ arstfmt -i 08092019_cmodtech.trace.log -o trxout
fatal error 'invalid character 0x10' at line: 3999​

This is happening on 3 otherwise fully functioning systems with the same specs. Ive tried permissions, different file systems, etc. No luck.

2
MP Server / Re: determining orphaned indexes?
« on: July 26, 2019, 05:16:41 AM »
Thanks Stephen. This makes sense. These application groups all have different retention requirements than what most of our heavy hitters do, most of them are legacy too. I will continue to go down this route

3
MP Server / determining orphaned indexes?
« on: July 25, 2019, 04:29:46 PM »
I am working on a migration, and I am seeing a ton of what I believe to be orphaned indexes in my CMOD system.

07/25/2019 17:57:57   ADMIN        893118   Error   No       24   Object >17939FAAB< in Application Group >EEA< not found in node >centera<  Srvr->prod1 192.168.1.2 non-SSL<-
07/25/2019 16:19:10   ADMIN        893110   Error   No       24   Object >29934FAAD< in Application Group >FEA< not found in node >centera<  Srvr->prod1 192.168.1.2 non-SSL<-

Based on my research/digging through the logs, It looks like there was some type of storage set modification back in 2013. I believe a node was deleted or modified, due to some kind of TSM retention requirement change. I think it may have been done improperly.

My issue is that I am trying to do an extract and reload from our current system into a new system. and part of our recon process is going to be checking our current tables, and making sure that the row count matches after we are done loading, to make sure that we got everything.

Just wondering how everyone has handled situations like this before, or if I am even heading down the right path. Feedback is appreciated, as always.


4
MP Server / Re: Database Migration
« on: July 10, 2019, 02:36:09 PM »
Last time I heard of this being done, the migration from Oracle to DB2 is problematic because of the different data types.  I'm interested to see if Alessandro has something to say about this - I vaguely remember him mentioning it previously.

-JD.

I was going to do this also, but we changed our mind. We were then going to switch from DB2 AIX to ORACLE RHEL, and we were going to do a complete re-ingest. Not sure if it's something required for this scenario, but something to keep in mind- if they plan on going to new storage or anything like that "maybe" as part of a larger migration

5
MP Server / Re: Database Migration
« on: July 10, 2019, 07:12:05 AM »
How big is your production environment? Do you plan on upgrading CMOD from 9.5 to 10.1? Do you plan on upgrading storage medium (tsm, icos..etc..)

6
MP Server / Re: Order of updating DB2, CMOD and Linux
« on: July 03, 2019, 09:57:00 AM »
For IBM CMOD Upgrades, if you're going to take an outage, you do everything that needs to be done at once.  If you have different teams, you have the OS upgraded first, then the DBAs and CMOD Admins can work in parallel after the system comes back up.

-JD.

I've done this two different ways.

Process One

1) We did AIX/DB2/CMOD on different weekends, this took a while because we had numerous tiers, but it was a very large system, for from what i understand was one of the "top 20" largest customers of CMOD.

One weekend- AIX

Test for a month, verify stability

One weekend - DB2

Test for a month, verify stability

One weekend - CMOD (Backup site)

Test for a month, point all users to this backup site

One weekend - CMOD (Primary site) ONCE EVERYTHING WAS VERIFIED

Process Two

Over a Weekend.

1) SA's did AIX upgrade / patches , quick verification. DBA's hopped in, upgraded/patched DB2, quick verification, Then they gave us CMOD...then we did some loads/testing. And that was really it. It was a very very small system.. < 1TB of cache. From my knowledge, system is still stable.



7
MP Server / Re: Ondemand - data restoration after removing app gr
« on: July 02, 2019, 06:04:55 AM »
Consider adding it as an Enhancement Request.  :)

Sounds like adding a recycling bin to cmod :)

Actually, a pretty good idea depending on the situation.

8
Windows Client / Re: Single sign-on for client
« on: June 24, 2019, 04:58:01 AM »
I am very interested in this as well.

I tried this with a client as well back in 2015, and after working with with IBM we were under the impression that we COULD do it with the thick AND admin client!

9
MP Server / Re: Spectrum Protect - Tivoli with CMOD Storage Question
« on: June 05, 2019, 05:34:13 AM »
Hi,

Not sure where to post this or
     if there is a separate Spectrum Protect User Group somewhere let me know


https://adsm.org/forum/index.php?whats-new/posts/527812/

10
MP Server / Re: Cannot start CMOD 10.1 with TSM 8.1
« on: June 04, 2019, 07:02:04 AM »
Found this on developer.ibm.com -

Researched the error shared: Error: Connector exited with error:
'ANS0238E (RC2041) The sequence of calls is invalid.' and found the
following explanation about this TSM Error:

ANS0238E - The sequence of calls is invalid.- Explanation
https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.2/com.ibm.itsm.msgs.client.doc/msg-ANS0238E.html

Since the issue is intermitent, it maybe caused by network/server
congestion and changing the schedule start times so that fewer backups
run at the same time seems to usually resolve the errors.


11
MP Server / Re: Cmmunication failure
« on: May 27, 2019, 06:48:43 PM »
I saw this issue about 5 years ago, and it was actually a memory leak with our version of Xenos. Does it happen intermittently? Can you load other files?

I would first check your uLimits, I believe stack needs to be set to unlimited, no files a minimum of 791339. Can't seem to locate the IBM requirements- but that's two that jumped out at me that I remember setting

12
MP Server / Re: Cmmunication failure
« on: May 25, 2019, 01:17:34 PM »
I would start with a complete system trace, and go from there.

What is your server setup? Single library server? multiple Object single Library Server? Local DB2 database on the library server?

13
Windows Client / Re: Admin client 9502 - Adding new user fails
« on: May 23, 2019, 05:15:44 PM »
couple suggestions

1) log out and login of the client (i've seen little things like that work..)
2) check out the arsuser table and query on the UID it is complaining about
3) triple triple check you aren't trying to create a user that already exists (done this myself in large systems..)

14
MP Server / Re: Files failing to load into Ondemand
« on: May 19, 2019, 04:06:26 PM »
usually on AIX/RHEL when I see this issue - it says that the application doesn't exist, or the account loading it does not have permissions to do so, check there.

Other then that, did you try running a trace to see if you can catch an error that way as well? They tend to be more informative.

15
z/OS Server / Re: System Log query
« on: May 19, 2019, 04:04:58 PM »
Thanks for the input !  Has anyone found a way to break up the msg_text in Application Group and as an extra, has anyone added the Foldername as a field/filter?

Thanks again

I believe I have in the past and I did it with SED/AWK... Scrape the text after ( and between ) ?

Also side note - we don't currently have anything setup to monitor our logs. So in the event of a production issue - I usually just copy everything from the system log and do a text to columns on ( and ). This has also proven to be life saving when troubleshooting prod issues, asked for load metrics..or etc..in a flash. Not really practical for your use case, but worth noting.

Pages: [1] 2 3 4 5 6 ... 22