Author Topic: Ondemand not showing error message  (Read 1521 times)

Gobi21

  • Newbie
  • *
  • Posts: 35
    • View Profile
Ondemand not showing error message
« on: May 20, 2013, 06:24:21 AM »
Hi,

I am running the ondemand load process for a file and its failing.

Ondemand process is not showing any error message.
Preparing load for GZZAF0001.AZZAF0001.201305201249341030.IND
File ready for load GZZAF0001.AZZAF0001.201305201249341030
Running Load...
LOAD COMMAND: /opt/ondemand/bin/arsload -f -n -v -u admin -p adminldn -g GZZAF0001 -a AZZAF0001 /sbcimp/dyn/data/RAR/OD_App1/arsload_GI/ATFBTXS1_GI/GZZAF0001.AZZAF0001.201305201249341030
arsload: Processing file >/sbcimp/dyn/data/RAR/OD_App1/arsload_GI/ATFBTXS1_GI/GZZAF0001.AZZAF0001.201305201249341030<
arsload: 05/20/13 12:55:19 -- Loading started, --UNKNOWN-- bytes to process
Loaded 0 rows into the database
Document compression type used - .  Bytes Stored = >0<
arsload: 05/20/13 12:55:19 Loading failed
arsload: Processing failed for file >/sbcimp/dyn/data/RAR/OD_App1/arsload_GI/ATFBTXS1_GI/GZZAF0001.AZZAF0001.201305201249341030<
arsload: Processing has stopped.  The remaining files will NOT be processed.

Could you please let me know how to see the log file/exact error message with respect to this load?

Thanks for your support.

Justin Derrick

  • IBM Content Manager OnDemand Consultant
  • Administrator
  • Hero Member
  • *****
  • Posts: 1552
  • CMOD Guru for hire...
    • View Profile
    • Tenacious Consulting
Re: Ondemand not showing error message
« Reply #1 on: May 21, 2013, 10:06:53 AM »
Try running arsload from inside the directory where the file resides, and just specify the file name on the arsload command line.

-JD.
#Install, #Educate, #Repair, #Upgrade, #Migrate, #Enhance, #Optimize.

IBM CMOD Professional Services: http://TenaciousConsulting.com
Call:  +1-866-533-7742  or  eMail:  jd@justinderrick.com
IBM CMOD Wiki:  https://CMOD.wiki/

Interests: #AIX #Linux #Multiplatforms #DB2 #TSM #SA #Performance #Security #Audits #Customizing #Availability #HA #DR #Training

danielito

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Ondemand not showing error message
« Reply #2 on: July 27, 2017, 07:03:03 AM »
Hello
I did a Change from 8.5 to 9.5 and after the update I can't find any messege for the Error reason

calling '/opt/ondemand/V9.5/bin/arsload -I XXXXXXX -g 05-do21 -a 05-do21-KDG03 -nf U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp'
ParaInfo Load Id = XXXXXXXXXX 05-do21
2017-07-18 15:59:33.739494: ARS4315I Processing file >U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp<
2017-07-18 15:59:33.739597: ARS4334I Load Version <9.5.0.8>  Operating System <Linux> <#1 SMP Sat Apr 22 02:41:35 EDT 2017.3.10.0-514.21.1.el7.x86_64>  OS Userid <ADMIN>  Install Location </opt/ondemand/V9.5/> Data(unlimited KB) Stack(8192 KB) Core(0 512-blocks) Cpu(unlimited seconds) File(unlimited 512-blocks) Nofiles(128000) Threads(0) Processes(15079)
2017-07-18 15:59:33.739654: ARS4335I Server Version <9.5.0.8>  Operating System <Linux> <#1 SMP Sat Apr 22 02:41:35 EDT 2017.3.10.0-514.21.1.el7.x86_64>  Database <ORACLE> <>
2017-07-18 15:59:33.753839: ARS4339I Application Group >05-do21<
2017-07-18 15:59:33.753870: ARS4340I Application >05-do21-KDG03<
2017-07-18 15:59:33.753890: ARS4341I Storage Set >Cache Only - Library Server<
2017-07-18 15:59:33.753908: ARS4342I Storage Node >Cache Only - Library Server<
2017-07-18 15:59:33.755229: ARS4302I Indexing started, 16428018 bytes to process
                          : APK415I CC=YES
                          : APK415I CCTYPE=A
                          : APK415I CONVERT=YES
                          : APK415I CPGID=500
                          : APK415I MCF2REF=CPCS
                          : APK415I TRC=NO
                          : APK415I FILEFORMAT=RECORD
                          : APK415I DCFPAGENAMES=NO
                          : APK415I UNIQUEBNGS=YES
                          : APK415I IMAGEOUT=ASIS
                          : APK415I INDEXOBJ=ALL
                          : APK415I INDEXSTARTBY=1
                          : APK415I INSERTIMM=NO
                          : APK415I FORMDEF=DUMMY
                          : APK415I FDEFLIB=/export/home/cmod/afpload/reslib/fdeflib
                          : APK415I PDEFLIB=/export/home/cmod/afpload/reslib/pdeflib
                          : APK415I OVLYLIB=/export/home/cmod/afpload/reslib/overlib
                          : APK415I FONTLIB=/export/home/cmod/afpload/reslib/fontlib
                          : APK415I RESTYPE=ALL
                          : APK415I INPUTDD=/data/cmod/DOMSafp/05/U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp
                          : APK415I OUTPUTDD=/data/cmod/DOMSafp/05/U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp.out
                          : APK415I INDEXDD=/data/cmod/DOMSafp/05/U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp.ind
                          : APK415I RESOBJDD=/data/cmod/DOMSafp/05/U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp.res
                          : APK440I ACIF AT IPTR923 HAS COMPLETED NORMALLY WITH RETURN CODE 0.
2017-07-18 15:59:34.119515: ARS4308I Indexing completed
2017-07-18 15:59:34.119615: ARS4312I Loading started, 102241 bytes to process
2017-07-18 15:59:34.656545: ARS1140I Resource /data/cmod/DOMSafp/05/U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp.res matches the resource >2-1-0<
2017-07-18 15:59:34.668988: ARS1143I The field name 'kundeninstr' found in the index file does not match any expected fields.  The field will be ignored.
2017-07-18 15:59:34.669028: ARS1143I The field name 'land' found in the index file does not match any expected fields.  The field will be ignored.
2017-07-18 15:59:34.669115: ARS1146I Loaded 0 rows into the database
 
load failed for U_05_IB_BT_PDX_TEV_000_DU_POSS_QUER_NORM_COPY_20170718_073201.afp  -  moved to failed


In this case the Date had a wrong form  %mm/%dd/%Y

But on the old Server I had a Error Message that the Date could not be convertet to this form

Is there any change that I have to do in the Scripts ?

kind regards
Daniel

BSwetzes

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Ondemand not showing error message
« Reply #3 on: February 28, 2018, 04:02:43 AM »
CMOD 9.5 does not put the error in the load log. It displays it to std output or error out. You need to redirect that to a file (when you start the script redirect the outputs to a file: >somelogfile.log 2>&1. The error will look something like this:
2018-02-27 14:16:23.843982: ARS1127E Row 2:  The string "817117" has a length of 6 and the field has a maximum length of 4
2018-02-27 14:16:23.844824: ARS4311E Loading failed
2018-02-27 14:16:23.844862: ARS4318E Processing failed for file >xxxxxxxxxx<
2018-02-27 14:16:23.863530: ARS4327E Processing has stopped.  The remaining files will NOT be processed.