Author Topic: ODWEK 8.5 installation problem CentOs 64-bit  (Read 880 times)

adomeij

  • Newbie
  • *
  • Posts: 9
    • View Profile
ODWEK 8.5 installation problem CentOs 64-bit
« on: September 07, 2015, 01:02:05 AM »
Hi all!
I'm trying to install ODWEK for Linux in a Virtualbox virtual machine (Host Win7 64-bit, guest CentOS 64-bit).
The installation program
sudo ./odweklinux.bin -i console
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
Launching installer...
Exception in thread "main" Preparing CONSOLE Mode Installation...
===============================================================================
Choose Locale...
----------------
    1- Deutsch
  ->2- English
    3- Español
    4- Français
    5- Italiano
    6- Português  (Brasil)
CHOOSE LOCALE BY NUMBER: 2
=======================================================
Installer User Interface Mode Not Supported
Unable to load and to prepare the installer in console or silent mode.
=======================================================

And I have been 'forced' to add some 32-bit rpms to get this far (since the installer launched is a 32-bit jre), libXtst and its dependent package(s), libc and some more that I can't recall. I'm guessing that I'm still missing one (or more) 32-bit packages that Installanywhere relies on.

Does anybody have a list of required rpms for installAnywhere used by the odweklinux.bin program?

the /tmp/odweklog.txt reports the followin error:

Selected Locale = English
XMLScriptReader: unable to parse the provided script file.  File may have been invalid...
java.lang.NullPointerException
        at ZeroGfg.a(DashoA10*..)
        at ZeroGfg.b(DashoA10*..)
        at ZeroGfh.a(DashoA10*..)
        at ZeroGfe.a(DashoA10*..)
        at ZeroGfg.a(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.t(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.j(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.f(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
        at com.zerog.ia.installer.Main.main(DashoA10*..)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:618)
        at com.zerog.lax.LAX.launch(DashoA10*..)
        at com.zerog.lax.LAX.main(DashoA10*..)
Unable to load the script.
SHUTDOWN REQUESTED

Please advise
/Anders

adomeij

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: ODWEK 8.5 installation problem CentOs 64-bit
« Reply #1 on: September 07, 2015, 01:22:41 AM »
The fp10 odweklinux.bin seems to run OK although it ends with
===============================================================================
IBM OnDemand Web Enablement Kit for Linux
-----------------------------------------
IBM OnDemand Web Enablement Kit for Linux requires version 8.5.0.0 or higher to
be installed first.
The installer will now quit.

which is a very irritating 'chicken and egg' conundrum :-)

Alessandro Perucchi

  • Hero Member
  • *****
  • Posts: 944
    • View Profile
Re: ODWEK 8.5 installation problem CentOs 64-bit
« Reply #2 on: September 08, 2015, 12:06:26 AM »
The fp10 odweklinux.bin seems to run OK although it ends with
===============================================================================
IBM OnDemand Web Enablement Kit for Linux
-----------------------------------------
IBM OnDemand Web Enablement Kit for Linux requires version 8.5.0.0 or higher to
be installed first.
The installer will now quit.

which is a very irritating 'chicken and egg' conundrum :-)

Hello, you MUST first install the ODWEK package available in your ibm passport advantage access, and only then you will be able to apply the fix pack to it.
That's the way it is with CMOD and ODWEK, always the base package first (which contains the license) and then the fix pack (which doesn't have the license).
Alessandro Perucchi

#Install #Migrations #Conversion #Educate #Repair #Upgrade #Migrate #Enhance #Optimize #AIX #Linux #Multiplatforms #DB2 #Windows #Oracle #TSM #Tivoli #Performance #Audits #Customizing #Availability #HA #DR #JavaApi #ContentNavigator #ICN #WEBi #ODWEK #Services #PDF #AFP #XML

adomeij

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: ODWEK 8.5 installation problem CentOs 64-bit
« Reply #3 on: September 08, 2015, 01:20:24 AM »
Hi Alessandro,
Thanks for the info,.
I'm fully aware that I first need to install the 8.5.0.0 base before applying the fp :-)

What I was trying to point out was that the InstallAnywhere in FP10 runs fine, whereas the InstallAnywhere in the Base version does not, it claims not to  not 'support' console or silent mode.

I suspect that this is because the Installanywhere used in the 8.5.0.0 base is a 32-bit version and I am missing some 32-bit rpms in my installation. The question is which (ncurses maybe) package(s).

OR the error message is 'bogus' i.e. something else is broken -- but the installer displays an incorrect error message??

From the install log:
XMLScriptReader: unable to parse the provided script file.  File may have been invalid...
java.lang.NullPointerException
        at ZeroGfg.a(DashoA10*..)
        at ZeroGfg.b(DashoA10*..)
        at ZeroGfh.a(DashoA10*..)
        at ZeroGfe.a(DashoA10*..)
        at ZeroGfg.a(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.t(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.j(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.f(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
        at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
        at com.zerog.ia.installer.Main.main(DashoA10*..)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:618)
        at com.zerog.lax.LAX.launch(DashoA10*..)
        at com.zerog.lax.LAX.main(DashoA10*..)
Unable to load the script.

Missing a 32-bit XML library could possibly/probably be the source of that error (I seriously doubt the XML file is corrupt since others have successfully installed the from it)

So as my system stands -- it's  impossible to install 8.5.0.0 (and yes I have downloaded it more than once and the problem is consistent) or some prereq for InstallAnywhere 32-bit is missing.

Anyvbody have a list of prereqs for InstallAnywhere lying around??

Rgds
/Anders

walkej

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • About Me
Re: ODWEK 8.5 installation problem CentOs 64-bit
« Reply #4 on: September 27, 2017, 10:56:24 AM »
I saw this recently with the ICN 3.0.1 installer, and running:
export DISPLAY=""
before the installer solved the issue. It seems to be something strange about the installer configuration...

(saw this as I was looking for help on the other issue, found the answer here: https://community.flexerasoftware.com/showthread.php?222889-Product-Failed-to-install-with-error-quot-Installer-User-Interface-Mode-Not-Supported-quot/page2)