Author Topic: Upgrade Approach for CMOD MP 9.5, TSM 7.1, and DB2 10.5 on AIX  (Read 802 times)

tjspencer2

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
So here's a fun one - a CMOD platform upgrade !!!

What I'm doing:
Moving from 9.5.0.7 to 10.1.0.3 on AIX 7.2 LPARs.

What I'd like to get:
A recommendation for how to best break the change up into maybe 2 releases, test, and release separately to production.

My architecture is as follows:
CMOD Library Server MP 9.5.0.7 on Unix LPAR 1
- Running DB2 10.5 - planning to leave at 10.5 unless recommend other?
- Running TSM Client 7.1.4
-- Will be installing Enhanced Records Management (new)
-- Will be installing FTS Server [on Library Server in DEV] (new)
-- Upgrading PDF Indexer to 10.1
-- Upgrading ODF to 10.1
TSM/Spectrum Server 7.1.1.100 on Unix LPAR 2
- Running DB2 10.5

My very high-level approach:
1. Upgrade TSM 7.1.1.100 to 8.1 (Unless it's possible to NOT have to do this and leave TSM Server at existing level and upgrade after I've put CMOD 10.1 in production?)
2. Install Spectrum 8.1 client on Library Server (Unless it's possible to just upgrade the client to 7.1.8.2 and retain TSM 7.1.1.100 as my TSM Server)
3. Upgrade CMOD from 9.5 to 10.5.0.3.

As I appreciate it from IBM, I could start with the TSM client on the Library Server LPAR - upgrade it to 7.1.8 and then apply fixpack 7.1.8.2 - this fixpack is necessary for arssockd to start for those using this client.  The question is can my 9.5 MP server talk through a 7.1.8.2 client to the 7.1.1.100 TSM Server as a test, and THEN can I upgrade ONLY my CMOD Server to 10.5 in this configuration and talk to TSM Server 7.1.1.100.  And then I could follow that up with a TSM 7.1 to Spectrum 8.1 Upgrade.

Thoughts/ recommendations?


Ed_Arnold

  • Hero Member
  • *****
  • Posts: 916
    • View Profile
Re: Upgrade Approach for CMOD MP 9.5, TSM 7.1, and DB2 10.5 on AIX
« Reply #1 on: April 30, 2018, 08:19:32 AM »
tj -

This will take you to what's supported for each level of CMOD.

http://www-01.ibm.com/support/docview.wss?uid=swg27049168

If this doesn't answer your questions, let us know.

Ed
#zOS #ODF

Ed_Arnold

  • Hero Member
  • *****
  • Posts: 916
    • View Profile
Re: Upgrade Approach for CMOD MP 9.5, TSM 7.1, and DB2 10.5 on AIX
« Reply #2 on: April 30, 2018, 12:52:30 PM »
Expanding a bit as this is an interesting question.

CMOD 9.5 supports Tivoli 6.4 Client and future fixpacks

https://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProduct?deliverableId=1363650145499#!

CMOD 10.1 supports Tivoli 8.1 Client and future fixpacks

https://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProduct?deliverableId=E877A7C04AB511E5BB33E7199C786195

If I'm reading this correctly then you have to do the TSM upgrade before the CMOD upgrade.

Ed
#zOS #ODF

rcarcamo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Upgrade Approach for CMOD MP 9.5, TSM 7.1, and DB2 10.5 on AIX
« Reply #3 on: September 12, 2019, 03:40:55 PM »
Hi tjspencer2,

1- What was the reason for the upgrade?
2- Did you have problems between CMOD 9.5 and AIX 7.2?

I mean, in the compatibility matrix report it shows that CMOD is not supported in AIX 7.2 ... but I want to know if you had problems?
« Last Edit: September 12, 2019, 03:42:41 PM by rcarcamo »

Justin Derrick

  • IBM Content Manager OnDemand Consultant
  • Administrator
  • Hero Member
  • *****
  • Posts: 1777
  • CMOD Guru for hire...
    • View Profile
    • Tenacious Consulting
Re: Upgrade Approach for CMOD MP 9.5, TSM 7.1, and DB2 10.5 on AIX
« Reply #4 on: September 13, 2019, 12:14:37 PM »
And I've recently discovered an incompatibility between TSM Client v7.1.6.5 and TSM Server v8.1.x.  There's apparently a new security profile in the v8.1.x servers, which may disable access to storage nodes.  Something about setting security on the server to 'transitional' rather than 'strict'.  I'll post more info about it when we get it resolved.  :D

-JD.
#Install, #Educate, #Repair, #Upgrade, #Migrate, #Enhance, #Optimize.

IBM CMOD Professional Services: http://TenaciousConsulting.com
Call:  +1-866-533-7742  or  eMail:  jd@justinderrick.com
IBM CMOD Wiki:  https://CMOD.wiki/

Interests: #AIX #Linux #Multiplatforms #DB2 #TSM #SA #Performance #Security #Audits #Customizing #Availability #HA #DR #Training

rcarcamo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Upgrade Approach for CMOD MP 9.5, TSM 7.1, and DB2 10.5 on AIX
« Reply #5 on: September 17, 2019, 04:36:10 PM »
And I've recently discovered an incompatibility between TSM Client v7.1.6.5 and TSM Server v8.1.x.  There's apparently a new security profile in the v8.1.x servers, which may disable access to storage nodes.  Something about setting security on the server to 'transitional' rather than 'strict'.  I'll post more info about it when we get it resolved.  :D

-JD.

Something similar we found with other coworkers, for versions of TSM 6.3 server and the TSM 7.1.8 clients..... we had to downgrade to the 6.3 client versions.