Author Topic: Message Number 61 and Ambiguous Results  (Read 133 times)

Rod Scott

  • Newbie
  • *
  • Posts: 13
    • View Profile
Message Number 61 and Ambiguous Results
« on: June 19, 2018, 10:41:39 AM »
We have a report that will not load. Several of us have taken time to work on this report for the last two weeks making changes to the INDEXER Parameters with no success.  It gets a Message number 61 which, according the the Messages and Codes manual is merely informational, and not indicative of an error.
 
Strangely enough, when looking at the System Log two different lines of data are produced, one of which says under view "Yes", the second line has "No" in the same column.  We don't see that for Message 87 successful loads. We can view the first one, but not the second.

Is there something insidious about Message Number 61 that would suggest a problem exists?

The input dataset has a x'F1' in the first byte of the first record, with an LRECL of 133. All mainframe data looks clean with no hex nulls or other non alphabetic/numberic data other than x'40' spaces.

OS390 Indexer Parms:
CC=YES
INDEXOBJ=ALL
TRC=NO
INDEXSTARTBY=0
CONVERT=NO
FILEFORMAT=RECORD
CPGID=500
CCTYPE=A
MCC2ANSI=Y
LINEOFFSET=ASPRINTED
/*LINEOFFSET=ASREAD*/
BREAKYES=OR
GROUPMAXPAGES=9999
TRIGGER1=*,1,X'F1',(TYPE=GROUP)
FIELD1=0,1,1,(TRIGGER=1,BASE=0)
INDEX1=X'C4E4D4D4E8',FIELD1,(TYPE=GROUP,BREAK=YES)/* DUMMY */
INPEXIT=PAGEBRK2
INPEXITNEW=Y


Thanks,
Rod Scott
"Still New to CMOD"

 

BCBSAL

#ConversionFromInfoPac
#CMOD

Greg Ira

  • Full Member
  • ***
  • Posts: 203
    • View Profile
Re: Message Number 61 and Ambiguous Results
« Reply #1 on: June 20, 2018, 05:06:43 AM »
Message 61 is simply a record of what you updated when you made the changes to the indexer parameters.  It always comes out with two records, one is viewable the other is not.  This is unrelated to your load issues.  If you could provide us the contents of your 88 record we may be able to help.