Author Topic: Load from ARSDOC GET  (Read 71 times)

Steve Lance

  • Newbie
  • *
  • Posts: 11
    • View Profile
Load from ARSDOC GET
« on: August 22, 2018, 12:23:22 PM »
I did an ARSDOC GET and received a document file and an index file.  They seem to be in binary.  What can I do to get them in a readable format?

Also, when I try to load the files, I am receiving an error "" not in Y-m-d format.  I change the format in the application to m/d/Y and receive "2018-08-20" not in m/d/Y format.  Any suggestions on how I can correct the error?

Stephen McNulty

  • Global Moderator
  • Newbie
  • *****
  • Posts: 28
    • View Profile
Re: Load from ARSDOC GET
« Reply #1 on: August 23, 2018, 04:33:07 AM »
what is the Data Type for the document that you are Getting?    (check Application definition, view information tab).  In our shop it would normally be AFP, so I would just change the document file extension to .afp and use an AFP viewer.

for the date format question, you need to update the application (change the Application, Load information tab). Change the Format of your date field to %Y-%m-%d  (or when in the field, press help, then choose Date and Time formats, they will all be listed)
#ISERIES #ODWEK #XML

Steve Lance

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Load from ARSDOC GET
« Reply #2 on: September 05, 2018, 09:13:27 AM »
I found the problem but I don't have a solution.  I have three date/time indexes.  The last index was added a few weeks ago.  So, the documents I am trying to load do not have a date/time for this last index.  That is why I am getting "" could not be converted to a date from the format of %Y-%m-%d %T.  I changed the Application to accept the current date/time but that did not work.  Any suggestions?

Greg Ira

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Re: Load from ARSDOC GET
« Reply #3 on: September 05, 2018, 10:46:42 AM »
Did you try setting a default value for that last date/time index?

Steve Lance

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Load from ARSDOC GET
« Reply #4 on: September 05, 2018, 11:06:52 AM »
I did default to the current date/time and that did not work.

Greg Ira

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Re: Load from ARSDOC GET
« Reply #5 on: September 05, 2018, 12:26:07 PM »
Did you use the 't' in the client or add the default parm to the indexing?
On multiplatform you can do the following to pull in a default date using regular expressions.
FIELD2=UL(0.00,1.82),LR(8.50,2.06),0,(TRIGGER=1,BASE=0,REGEX='[A-Z][a-z]+ [0-9]+, [0-9]{4}',DEFAULT='January 1, 1970')

We try to use something that makes it obvious it's a default value.


Justin Derrick

  • IBM Content Manager OnDemand Consultant
  • Administrator
  • Hero Member
  • *****
  • Posts: 1552
  • CMOD Guru for hire...
    • View Profile
    • Tenacious Consulting
Re: Load from ARSDOC GET
« Reply #6 on: September 05, 2018, 12:30:59 PM »
There's an article in the CMOD Wiki about Default Values:  https://cmod.wiki/index.php?title=Default_Values_and_the_Generic_Indexer

Let me know if it's useful.

-JD.
#Install, #Educate, #Repair, #Upgrade, #Migrate, #Enhance, #Optimize.

IBM CMOD Professional Services: http://TenaciousConsulting.com
Call:  +1-866-533-7742  or  eMail:  jd@justinderrick.com
IBM CMOD Wiki:  https://CMOD.wiki/

Interests: #AIX #Linux #Multiplatforms #DB2 #TSM #SA #Performance #Security #Audits #Customizing #Availability #HA #DR #Training

Greg Ira

  • Full Member
  • ***
  • Posts: 201
    • View Profile
Re: Load from ARSDOC GET
« Reply #7 on: September 05, 2018, 12:39:03 PM »
I recall tricking the indexer into using the default value from the admin client by using another trigger on a constant in the field such as the ':' in the time eg 10:30.
The field was based off of that trigger.  If the trigger can't find the ':' it never checks the field and uses the default.