Author Topic: FNDRPTOND always returns message 'FOLDER xxxxxxxx NOT FOUND  (Read 564 times)

Joe Wolken

  • Jr. Member
  • **
  • Posts: 78
  • CMOD iSeries Consultant
    • View Profile
    • OAS Corp.
FNDRPTOND always returns message 'FOLDER xxxxxxxx NOT FOUND
« on: October 10, 2019, 01:16:21 PM »
I am trying to implement the FNDKEYOND command from a 5250 session to the OnDemand Client for which I have launched and logged onto the QRLROCD.EXE app on the PC.  I am using a system admin OnDemand account.

I can use the app to successfully open, search and retrieve from the any of the defined Folders.

However, no matter which Folder I specify in my FNDKEYOND API call, the 5250 sessions says that my retrieval request has been transferred to the OnDemand client viewer program.  BUT, I get a message from qrlrocd saying "FOLDER xxxxxx NOT FOUND"  with an OK button and no added details or logs.
The xxxxxxx is the exact name of the folder that I specified in the FNDKEYOND command, so the folder name appears to be getting down to the client

Example:
FNDKEYOND FOLDER('System Log') KEYFLD((MSG_NUM *EQ 30))

Message from qrlrocd is: FOLDER System Log NOT FOUND
It does not even find the System Log.  Is there piece of setup that I am missing?  Or has anyone encountered this issue? 
I am running server version 10.1.0.5 with a v.10.1 client.
Installation, Upgrade, Migration, Administration, Integration, Customization, Training, and more!

Call: 512-402-1123
email: wolkenj@oascorp.com 
Click: http://www.OASCorp.com

Stephen McNulty

  • Jr. Member
  • **
  • Posts: 56
    • View Profile
Re: FNDRPTOND always returns message 'FOLDER xxxxxxxx NOT FOUND
« Reply #1 on: October 11, 2019, 03:48:54 AM »
Joe,  the command needs to provide the field definition name from the Folder instead of the app group

I had same bad result with your command,

instead use;

FNDKEYOND FOLDER('System Log') KEYFLD(('Msg Num' *EQ 30))
#ISERIES #ODWEK #XML

Joe Wolken

  • Jr. Member
  • **
  • Posts: 78
  • CMOD iSeries Consultant
    • View Profile
    • OAS Corp.
Re: FNDRPTOND always returns message 'FOLDER xxxxxxxx NOT FOUND
« Reply #2 on: October 11, 2019, 05:55:09 AM »
I agree.  I tried it using both types of field names (just for grins). Unfortunately, this is not the issue.  Here is another example:

FNDKEYOND FOLDER (TESTLOAD) KEYFLD(('Claim Number' *EQ TEST1))

I get the same error "FOLDER TESTLOAD NOT FOUND"

This is despite that when I use F4 to prompt the command, then use F4 to prompt the Folder, I see the complete list of Folders defined on the default (and only) Instance on the system.  I see TESTLOAD in the list.

I support other OnDemand v.10 iSeries servers and the function works very simply without issue.  Here I can not even determine if it is a client or server setting issue as there is nothing to use to debug.
Installation, Upgrade, Migration, Administration, Integration, Customization, Training, and more!

Call: 512-402-1123
email: wolkenj@oascorp.com 
Click: http://www.OASCorp.com

Joe Wolken

  • Jr. Member
  • **
  • Posts: 78
  • CMOD iSeries Consultant
    • View Profile
    • OAS Corp.
Re: FNDRPTOND always returns message 'FOLDER xxxxxxxx NOT FOUND
« Reply #3 on: October 11, 2019, 11:16:39 AM »
Update - This same FNDKEYOND API worked perfectly and without issue on another PC in the network. We plan to investigate the difference between the two PCs and will update this thread.  Where we plan to look are:
- Differences in the Windows Firewall settings
- The failed PC was on an old Windows 7 PC that I was using Remote Desktop to access.
Installation, Upgrade, Migration, Administration, Integration, Customization, Training, and more!

Call: 512-402-1123
email: wolkenj@oascorp.com 
Click: http://www.OASCorp.com