Author Topic: ICN CMOD docs do not display correctly  (Read 335 times)

grahaj7

  • Newbie
  • *
  • Posts: 1
    • View Profile
ICN CMOD docs do not display correctly
« on: August 09, 2022, 06:17:56 AM »
Hi!

We have recently installed both ICN (linux)  and CMOD (zOS).

We have ICN connected to the CMOD repositories, and we are able to search and find documents.  But we cannot view documents.  When we click to view a doc, we just get a blank screen with some grey boxes at the top.

This is just line data - JCL/JOB output.

If we download the file as text, it is unreadable.  If we download the doc as CSV, it actually is totally readable and we have some nice Job output in an excel spreadhseet.

WE opened a case with IBM and they're saying we need to install a viewer map, but the instructions on how to do that are not very detailed and I can't figure it out.   The only viewer we have is the "default viewer".  I see other viewers below but I can't select them in any way.

In addition, the vendor we are working with says we shouldn't have to install any viewer maps;  that viewing line data should just work out of the box.

Anyone else run into this or have any thoughts?
thanks!
Jenny

spond

  • Jr. Member
  • **
  • Posts: 22
    • View Profile
Re: ICN CMOD docs do not display correctly
« Reply #1 on: August 09, 2022, 07:39:59 AM »
Depending on which version of ICN and CMOD/ODWEK you have installed, the default viewer map should work fine, provided you want the HTML Line Viewer as your view type (this assumes that your desktop has the Default viewer map selected). Incidentally, download as 'As UTF8' should also give you readable output. Download 'As original' is probably EBCDIC since this is JCL output.

You can check this by going to the ICN Admin desktop, select Viewer Maps and then double click the Default viewer map, Then scroll down to the 1st occurrence where the Repository Type is Content Manager OnDemand and the File type is application/line and verify that it shows Line Data HTML Viewer in the Viewer column. If this is correct, you likely already have a properly configured viewer map.

Make sure you are using a supported browser (pretty much everything but Internet Explorer).

If that all looks ok, check the browser console for any errors. You can launch the browser console by entering control+shift+i at the search results screen and then right-click on the doc and select Open. If you see errors in the browser console, you should reopen your case with IBM and them know what those errors are.

For what it's worth, there have been many changes to the HTML Line Viewer so if you are back level in either CMOD/ODWEK or ICN, I would highly recommend upgrading.