Author Topic: Which TSM server version?  (Read 15286 times)

Michel de Kraker

  • Full Member
  • ***
  • Posts: 164
    • View Profile
    • SYSBLOX , AIX consultancy
Which TSM server version?
« on: February 02, 2011, 02:38:08 AM »
Hi All,

At the moment we are running TSM server version 5.4. We want to move to a TSM SSAM environment, so i will have to install a new TSM server. TSM 6.2 is a complete different setup in regards to TSM 5.5.5.0 which  i want to install. What do guys recommend ? Go for the "old" 5.5.5.0 version of for TSM 6.2? TSM 5.5.5.0 is out for 4 years now, will it be out of support next year?

Thx. Michel;

Alessandro Perucchi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1001
    • View Profile
Re: Which TSM server version?
« Reply #1 on: February 02, 2011, 03:05:34 AM »
Hello Michel,

Well I have found this page : http://www-01.ibm.com/software/support/lifecycleapp/PLCDetail.wss?synkey=V649976C05962P29&from=spf and it clearly states that the end of marketing for TSM 5.5 is 16.07.2010 for AAS (I don't know what it means).
For PPA (Passport Advantage), well the End Of Marketing is not yet reached.

But it has not yet an End Of Support date.

I suppose, that the End Of Support will happen in the middle of this year, but I really don't know. It would be better to ask your IBM representative if they have an idea of the EOS date.

Cheers,
Alessandro
Alessandro Perucchi

#Install #Migrations #Conversion #Educate #Repair #Upgrade #Migrate #Enhance #Optimize #AIX #Linux #Multiplatforms #DB2 #Windows #Oracle #TSM #Tivoli #Performance #Audits #Customizing #Availability #HA #DR #JavaApi #ContentNavigator #ICN #WEBi #ODWEK #Services #PDF #AFP #XML

Michel de Kraker

  • Full Member
  • ***
  • Posts: 164
    • View Profile
    • SYSBLOX , AIX consultancy
Re: Which TSM server version?
« Reply #2 on: February 02, 2011, 03:31:26 AM »
Thx Alessendro for your quick respone. Do you have already experience with tsm 6.X?

Kind regards,

Michel.

Justin Derrick

  • IBM Content Manager OnDemand Consultant
  • Administrator
  • Hero Member
  • *****
  • Posts: 2138
  • CMOD Guru for hire...
    • View Profile
    • Tenacious Consulting
Re: Which TSM server version?
« Reply #3 on: February 03, 2011, 01:33:17 AM »
I still recommend TSM 5.5 for now. 

For anyone considering upgrading, I've been advised to upgrade DIRECTLY to TSM 6.2, skipping the step to TSM 6.1.

-JD.
IBM CMOD Professional Services: http://TenaciousConsulting.com
Call:  +1-866-533-7742  or  eMail:  jd@justinderrick.com
IBM CMOD Wiki:  https://CMOD.wiki/
FREE IBM CMOD Education & Webinars:  https://CMOD.Training/

Interests: #AIX #Linux #Multiplatforms #DB2 #TSM #SP #Performance #Security #Audits #Customizing #Availability #HA #DR

Michel de Kraker

  • Full Member
  • ***
  • Posts: 164
    • View Profile
    • SYSBLOX , AIX consultancy
Re: Which TSM server version?
« Reply #4 on: February 03, 2011, 01:44:46 AM »
Hi JD,

Is there a reason for recommending 5.5? What about the support (out of date in 2011)

Thx.

Michel

Michel de Kraker

  • Full Member
  • ***
  • Posts: 164
    • View Profile
    • SYSBLOX , AIX consultancy
Re: Which TSM server version?
« Reply #5 on: February 10, 2011, 12:22:00 AM »
At the moment i have CMOD 8.4.0.3 installed. Is TSM 6.2 supported with this version of CMOD? I cannot find this info on the IBM Support site.

Thx.

Michel.

Justin Derrick

  • IBM Content Manager OnDemand Consultant
  • Administrator
  • Hero Member
  • *****
  • Posts: 2138
  • CMOD Guru for hire...
    • View Profile
    • Tenacious Consulting
Re: Which TSM server version?
« Reply #6 on: February 10, 2011, 01:28:55 AM »
I recommend 5.5.x because TSM 5.4 is the recommended version for 8.4.x.  Using 5.5 (which is still supported and receiving fixes) is less risky than jumping to 6.2 at the moment.

The versions of requisites that CMOD is tested with are always available in the readme for that version.

The URL: ftp://ftp.software.ibm.com/software/ondemand/fixes/v840/8.4.0.3/readme.txt

For 8.4.0.3:

3. OnDemand Testing Environment
-------------------------------------------------------------------------------

  The following is a list of the environments in which IBM tested the
  latest Release/PTF.

        AIX:
           AIX    - 5.3
           DB2    - 9.1
           TSM    - 5.4

        HP-UX:
           HP-UX  - B11.23 (V11i V2)
           DB2    - 9.1
           TSM    - 5.4.1

        SunOS:
           SunOS  - 5.10
           DB2    - 9.1
           TSM    - 5.4

        Windows:
           Windows   - 2003 R2
           DB2       - 9.1
           TSM       - 5.4

        Linux:
           RedHat - RHES release 4 U4
                    Kernel (2.6.9 glibc-2.3.4)
           SuSE   - SLES 10
                    Kernel (2.6.16 glibc-2.4-31)
           DB2    - 9.1
           TSM    - 5.4

        Linux on System z:
           RedHat - RHEL release 5 U0
                    Kernel (2.6.18-8.el5 glibc-2.5-12)
           SuSE   - SLES 10
                    Kernel  (2.6.16 glibc-2.4-31)
           DB2    - 9.1
           TSM    - 5.4


You're probably better off doing a full upgrade (db2, TSM, CMOD) before implementing your switch to SSAM.  Why run the risk of upgrading to old bugs?

-JD.
IBM CMOD Professional Services: http://TenaciousConsulting.com
Call:  +1-866-533-7742  or  eMail:  jd@justinderrick.com
IBM CMOD Wiki:  https://CMOD.wiki/
FREE IBM CMOD Education & Webinars:  https://CMOD.Training/

Interests: #AIX #Linux #Multiplatforms #DB2 #TSM #SP #Performance #Security #Audits #Customizing #Availability #HA #DR

Michel de Kraker

  • Full Member
  • ***
  • Posts: 164
    • View Profile
    • SYSBLOX , AIX consultancy
Re: Which TSM server version?
« Reply #7 on: February 10, 2011, 01:44:40 AM »
Thx JD,

I am not sure about your last statement. Can you be more specific?

Just to make things clear:

At the moment i am running:
CMOD 8.4.0.3
DB2 9.1
TSM 5.4

So when i upgrade to TSM 5.5.X (SSAM Configuration) i do not have to upgrade CMOD and DB2 according to this README, am i right?
I cannot upgrade my existing TSM server and convert it to SSAM. So i have to arsadmin retrieve all objects from the 5.4 TSM server and arsadmin store it in the 5.5.X TSM/SSAM server
This will be a lengthy process, i have calculated in total 2 months for 25 million objects.


Thx. Michel.

Alessandro Perucchi

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1001
    • View Profile
Re: Which TSM server version?
« Reply #8 on: February 10, 2011, 07:00:12 AM »
Hello Michel,

Do you have already experience with tsm 6.X?

No, absolutely no experience with TSM 6.x.

Even with CMOD 8.5, the supported TSM version is 5.5 or higher (http://www-01.ibm.com/support/docview.wss?rs=129&uid=swg27016455#Tivoli).

Cheers,
Alessandro

Alessandro Perucchi

#Install #Migrations #Conversion #Educate #Repair #Upgrade #Migrate #Enhance #Optimize #AIX #Linux #Multiplatforms #DB2 #Windows #Oracle #TSM #Tivoli #Performance #Audits #Customizing #Availability #HA #DR #JavaApi #ContentNavigator #ICN #WEBi #ODWEK #Services #PDF #AFP #XML

Michel de Kraker

  • Full Member
  • ***
  • Posts: 164
    • View Profile
    • SYSBLOX , AIX consultancy
Re: Which TSM server version?
« Reply #9 on: February 10, 2011, 07:28:11 AM »
Thx Alessandro,

So at the moment i am at TSM 5.4, do you also agree with Justin to go for 5.5.X instead of 6.2?
Or should i stick to TSM 5.4 for now, seems supported for CMOD 8.4.0.3

Michel.